Ubuntu en Android SDK r8

Als je een wat oudere Ubuntu gebruikt (9.10 in mijn geval), en je update je (Eclipse) omgeving naar r08 voor Android 2.2 support (en misschien ook r09 voor 2.3 support), dan kom je mogelijk de volgende fout tegen:

./emulator: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.11' not found (required by ./emulator)

Dit komt doordat specifiek de emulator binary tegen een te nieuwe glibc is gelinkt. Ik begrijp dat Google werkt aan een oplossing voor dit probleem, en tot die tijd lijkt de enige oplossing om een oudere emulator (uit r07) te installeren.

De Android tools voor r07 kan je eenvoudig downloaden via deze link. Plaats tools/emulator in je android-sdk-linux_86/tools (rename eventueel 'emulator' naar 'emulator.broken'), en je kan weer emuleren!

Last updated 19 april 2013 10:11 | filed under android
comments powered by Disqus